Internal Technical Issue (INC#039)
Incident Report for SIMPLY HITS NETWORK
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 22, 2024 - 22:09 UTC
Investigating
Update: 20th February 2024 - 16:30 GMT

We are currently experiencing an internal technical issue affecting the processing of emails, particularly those containing song requests. Our team is actively investigating the matter to resolve it as swiftly as possible.

Estimated Fix Time: 21st February 2024 - 00:15 GMT

We apologize for any inconvenience caused and appreciate your patience as we work to restore normal functionality. Further updates will be provided as soon as they are available.

Thank you for your understanding.

Simply Hits Network Operations Team
Posted Feb 20, 2024 - 23:56 UTC
This incident affects: Website Services, Communication Services, and Email Services.